Archiv des Autors: admin

Was ist whois?

ist ein , mit dem Informationen zu -Adressen und Internet Domains abgefragt werden können. Es wurde in RFC 3912 definiert. Diese Informationen beeinhalten insbesondere Angaben zu den Eigentümern und Verantwortlichen.

Mitunter wird mit Betriebssystemen ein entsprechendes Kommandozeilen-basiertes ausgeliefert. Die Nutzung erfolgt dann so:

  > whois information-information.de

bzw. IP-basiert

  > whois 216.73.216.82

Dies Ausgabe liefert Informationen zum Besitzer/Betreiber, inklusive Kontaktpersonen, Adressen u.ä. Aufgrund jüngerer Datenschutzanpassungen (wie z.B. DSGVO) sind die meisten Informationen allerdings nicht mehr direkt öffentlich abrufbar, womit der whois Eintrag an Nützlichkeit eingebüßt hat, wenn es z.B. darum geht, den Besitzer einer Domain zu finden.

Der Abruf der Daten muss also mindestens begründet werden, und steht eher generell autorisierten Stellen zur Verfügung.

Weiterführende Informationen

Veröffentlicht unter Internet | Verschlagwortet mit , | Hinterlasse einen Kommentar

Was ist VOIP (Voice Over IP)?

steht für Voice Over und beschreibt die Übertragung von gesprochener Sprache mit Hilfe des Internet Protokolls. Es ist synonym für die Gruppe von Software und Hardware, die dazu genutzt werden kann, um in dieser Form zu telefonieren.

Während in der Anfangszeit des VOIP Rechner mit Headsets genutzt wurden, um diese Möglichkeit zu nutzen, gibt es heute zahlreiche Endgeräte, die sich äußerlich nicht von üblichen Telefonen unterscheiden. Zudem ist es möglich, sowohl mit anderen VOIP-Anschlüssen aber auch mit regulären Telefonanschlüssen zu kommunizieren.
Vorteile des Voice Over IP
Die Vorteile des Voice Over IP sind vielfältig.

(mehr …)

Veröffentlicht unter Internet | Verschlagwortet mit , | Hinterlasse einen Kommentar

Was ist traceroute?

ist ein Analysewerkzeug, welches die Route zum Zielhost aufzeigt. Es wurde in RFC 1393 spezifiziert.

Dazu sendet das wiederholt Pakete an den Host, mit jeweils steigendem TTL (Time-To-Live) Wert. Ein Router verwirft Pakete mit TTL 1 und reduziert den TTL-Wert, wenn er ein Paket weitergibt.

(mehr …)

Veröffentlicht unter Internet | Verschlagwortet mit , | Hinterlasse einen Kommentar

Was ist ein TCP/IP-Paket?

steht für Transmission Control Protocol und ist ein verbindungsorientiertes, paketvermittelndes Transportprotokoll in Netzwerken. Es setzt oft auf dem (Internet ) auf, weshalb man von TCP/ spricht. TCP selbst ist in RFC 793 definiert.

TCP etabliert einen Kanal zwischen den beiden Endpunkten einer Kommunikation und erlaubt die Übertragung von Daten in beide Richtungen. Dabei wird der Datenstrom in Pakete, sog. TCP/IP-Pakete, zerteilt, die einzeln übermittelt werden.

Jedes Paket kann dabei eine andere Route zum Ziel nehmen. Daher kommen die Pakete mitunter in anderer Reihenfolge an. Am Ziel angekommen werden Sie in die richtigen Reihenfolge gebracht und wieder zusammengefügt.

(mehr …)

Veröffentlicht unter Internet | Verschlagwortet mit , , | Hinterlasse einen Kommentar

Was ist SIP (Session Initiation Protocol)?

Das Initiation Protocol () ist ein zur Steuerung einer Kommunikationssitzung zwischen zwei und mehr Teilnehmern.

Es ist in RFC 3261 spezifiziert.

Das Protokoll lehnt sich an das Hypertext Transfer Protocol an und bildet einen offenen, gut erweiterbaren Standard, der zum Beispiel in der -Telefonie häufig verwandt wird.

SIP dient dazu, die Kommunikation selbst auszuhandeln.

Der eigentliche Datenaustausch wird über separate Protokolle realisiert. Oft wird dazu das Session Description Protocol (SDP, RFC 4566) in SIP eingebettet, um Details zur der Video- und/oder Audio-Übertragung auszuhandeln.

Hier teilen sich die Kommunikationspartner mit, welche Codecs (Übertragungsmethoden) sie unterstützen können und mit welchem Protokoll sie die Daten übermitteln möchten.

SIP bietet Flexibilität.

(mehr …)

Veröffentlicht unter Internet | Verschlagwortet mit , , | Hinterlasse einen Kommentar